Hebron-Langley Primary Internet Outage

Resolved

This incident has been resolved.
Posted Jul 08, 2025 - 13:37 EDT

Investigating

The primary internet connection is down at Hebron-Langley and the site is currently running on cellular backup. Spectrum has been contacted and is dispatching a tech.
Posted Jul 02, 2025 - 18:12 EDT
This incident affected: Network (Hebron-Langley).