Romulus East Fiber Outage

Resolved

Comcast got it working and everything is online.
Posted Jul 11, 2025 - 09:08 EDT

Investigating

The primary fiber connection is down at Romulus East. Comcast is dispatching a tech and should arrive within 4 hours. The secondary connection is still operational.
Posted Jul 11, 2025 - 08:29 EDT
This incident affected: Network (10801 Romulus Network).