PingID is down, VPN and email sign-in may be affected

Resolved

This incident has been resolved.
Posted Oct 10, 2025 - 17:36 EDT

Monitoring

Databank has fixed the issue on their end and now both services are operational. We will continue to monitor for stability.
Posted Oct 01, 2025 - 11:16 EDT

Update

Databank has identified the issue on their end. Office 365 authentication has been fixed, however the VPN still remains down.
Posted Oct 01, 2025 - 11:02 EDT

Identified

It appears the issue is related to firewall upgrades performed by Databank last night. We are in contact with Databank for resolution.
Posted Oct 01, 2025 - 08:21 EDT

Investigating

PingID is giving an error when logging in to VPN or email. We are investigating the issue.
Posted Oct 01, 2025 - 06:54 EDT
This incident affected: Third Party Applications (Ping ID) and Infrastructure (Carter VPN).