Somerset Primary internet down

Resolved

This incident has been resolved.
Posted Nov 15, 2025 - 17:28 EST

Identified

The primary internet connection is down due to an outage with the service provider. There is no ETR at this time. Somerset is still operational on the secondary backup LTE connection.
Posted Nov 14, 2025 - 14:41 EST
This incident affected: Network (Somerset Network).